视听之窗

视听之窗专业视听投影论坛 → 视频会议网络互通碰到问题?小南带您详细了解交换机配置


  共有212人关注过本帖树形打印复制链接

主题:视频会议网络互通碰到问题?小南带您详细了解交换机配置

帅哥哟,离线,有人找我吗?
南方电讯
  1楼 博客 | 信息 | 搜索 | 邮箱 | 主页 | UC


加好友 发短信
等级:城市猎人 帖子:2522 积分:25436 威望:0 精华:0 注册:2018-1-22 10:48:00
视频会议网络互通碰到问题?小南带您详细了解交换机配置  发帖心情 Post By:2019-9-4 15:33:00 [只看该作者]


关键词:网络通信应用,视频通信,多媒体集成,南方电讯
基于网络的视频会议在系统部署调试和实际运行时,最常见的就是网络问题。今天小南带您从基础到深入来了解下,碰到网络互通的问题,如何合理运用交换机配置达到系统要求。
 
一、什么样的网络才能互通
通常情况下,两台电脑如何能才互通呢?如何才能不能互相访问呢?
最简章方法就是利用网段来解决,我们来举例。
 
1、两台电脑不能互相访问
假设:
PC1 ip地址:192.168.1.1/24
PC2 ip地址:192.168.2.1/24
要测试PC1和PC2的连通性:最简单的方法就是用PC1去PingPC2,查看Ping的结果。
 
很明显ping不通,PC1和PC2的ip在不同的网段,不能ping通。
那么什么样的情况能ping通呢?
2、如何才能互访
假设:
PC1的ip地址:192.168.1.1/24
PC2的IP地址:192.168.1.2/24
PC3的ip地址:  192.168.1.3/24
都在同一个网段内,用测试pc1是否能互访pc2与pc3,直接用pc1去ping pc2与pc3就行。
pc1去ping pc2
 
pc1去ping pc3
 
很明显,两个都是可以ping通的,因为PC1-PC5在同一个网段内,使用是相同的网关。
那么问题来了,如何让同一个网段的ip不能互通呢?如何让不同网段ip又能互通
?这里面我们就需要引进vlan了。
二、划分vlan,实现网络的互访与阻绝
上面我们已经演示了网络最简单的互通与不通的情况,在没有其它设置的情况下,同一个网段的ip地址,能互通,不同的网段的ip地址不能互通。而在实际项目中,并不是这么简单的,我们来看下不同vlan与不同网段之间的互通与阻绝如何实现。
还是这个拓扑图:
 
假设:
PC1的ip地址:192.168.1.1/24   连接LSW1交换机端口Ethernet 0/0/1
PC2的IP地址:192.168.1.2/24   连接LSW1交换机端口Ethernet 0/0/2
PC3的ip地址:  192.168.1.3/24   连接LSW1交换机端口Ethernet 0/0/3
PC4的ip地址:  192.168.1.3/24   连接LSW2交换机端口Ethernet 0/0/1
现在要让pc1与pc2互访,p1与pc3不能互通,pc1与pc4也不能互访,如何来配置交换机?(今天我们就以华为交换机为例)。
交换机配置(以华为交换机为例)
1、配置LSW1
<Huawei>system-view         //进入系统视图
[Huawei]sysname sw1         //给交换机命名
[sw1]vlan 10                  //创建VLAN10
[sw1-vlan10]vlan 20         //创建VLAN20
[sw1-vlan20]display vlan    //显示VLAN信息
[sw1-vlan20]quit         //退回上一级视图
[sw1]interface Ethernet 0/0/1          //进入以太网接口0/0/1
[sw1-Ethernet0/0/1]port link-type access         //配置接口类型为Access
[sw1-Ethernet0/0/1]port default vlan 10          //分配接口给VLAN10
[sw1-Ethernet0/0/1]quit                        //退回上一级视图     
[sw1]interface Ethernet 0/0/2           //进入以太网接口0/0/2
[sw1-Ethernet0/0/2]port link-type access       //配置接口类型为Access
[sw1-Ethernet0/0/2]port default vlan 10         //分配接口给VLAN10
[sw1-Ethernet0/0/2]quit        //退回上一级视图     
[sw1]interface Ethernet 0/0/3       //进入以太网接口0/0/3
[sw1-Ethernet0/0/3]port link-type access     //配置接口类型为Access
[sw1-Ethernet0/0/3]port default vlan 20       //分配接口给VLAN20
[sw1-Ethernet0/0/3]display vlan               //显示VLAN信息
小结:在LSW1中,把pc1与pc2分配在了vlan10,把pc3分配到了vlan20中。
2、LSW2交换机配置
命令与上面类似,就不一 一注释了,多看几篇就很容易理解。
<Huawei>system-view
[Huawei]sysname sw2
[sw2]vlan 10             //批量创建VLAN
[sw2]display vlan 
[sw2]interface Ethernet 0/0/1          //进入pc4的以太网接口0/0/1
[sw2-Ethernet0/0/1]port link-type access         //配置接口类型为Access
[sw2-Ethernet0/0/1]port default vlan 10          //分配接口给VLAN10
[sw2-Ethernet0/0/2]display vlan
在LSW2中,主要是把pc4划分给了vlan10
3、验证vlan
a、测试PC1和PC2的连通性。
 
因为在同一个vlan且在相同的网段,所以PC1和PC2能够ping通。
b、测试PC1和PC3的连通性
 
虽然pc1与pc3的ip地址在同一个网段里面,但PC1和PC3不在同一个vlan中,所以PC1和PC3不能ping通(pc1是属于vlan10,pc3是属于vlan20)。
c、测试PC1和PC4的连通性
 
很明显也pc1与pc4不能ping通,这个是为什么呢?
虽然PC1和PC4在同一个vlan且也在同一个网段中,但是Lsw1和Lsw2交换机没有配置trunk端口,access端口没有tag标记,通不过trunk端口,所以ping不通!
那么问题来了,如何才能让pc1与pc4互通呢?
三、如何使交换机间互相通信
上面我们提到了,pc1是属于LSW1交换机,pc4是属于SLW2交换机,虽然pc1与pc4是划分到了同一个vlan,且ip地址也在同一个网段,但仍然无法互相通信,主要是没有配置trunk接口,我们来配置下。
 
1、LSW1的配置
[sw1]interface Ethernet 0/0/4    // 进入交换机1与交换机2连接的接口0/0/4 
[sw1-Ethernet0/0/4]port link-type trunk       //配置接口类型为trunk
[sw1-Ethernet0/0/4]port trunk allow-pass vlan 10 20  //trunk口允许通过的VLAN10与vlan20
2、LSW2的配置
[sw2]interface Ethernet 0/0/3         // 进入交换机1与交换机2连接的接口0/0/3
[sw2-Ethernet0/0/3]port link-type trunk   //配置接口类型为trunk
[sw2-Ethernet0/0/3]port trunk allow-pass vlan 10 20 
//trunk口允许通过的VLAN10与vlan20

3、验证trunk接口配置:
测试PC1和PC4的连通性,并解释原因。
 
PC1和PC4能够ping通,因为交换机之间设置了trunk接口,使得不同vlan之间能够通过其他的交换机!
最后总结下:
1、什么情况下,我们才会去划分VLAN。
让网络进行逻辑隔绝,才会划分vlan!不同的vlan中,即使在相同的网段也不能ping通,
2、什么情况下,我们才会去配置trunk接口。
要让交换机和交换机之间连通,需要设置trunk接口。
南方电讯在多媒体通信及应用领域拥有二十多年规划设计和服务实施经验,希望能为更多行业用户提供更智能的统一协作解决方案。南方电讯“统一协作”区别于传统的融合通信,是集视频协作、语音协作、数据协作、IM协作、媒体协作于一体的解决方案。同时,以开放的架构打造全场景应用。南方电讯希望发挥统一协作巨大的力量,让企业经营者无惧任何距离、设备、平台或时间障碍,实现成本节约,助力企业数字化转型,赋予企业每个部门、每个员工随时都可以获取协作的力量。搜索“南方电讯”,可以免费预约体验云视频会议。http://www.putian-nst.com/chan-pin-zi-liao/list_135_1.html


 回到顶部